Electra 2.8 Soft Synthesizer – New Update Available Now

Tone2 Electra 2.8 New Update

Tone2 Audio has updated the synthesizer-workstation Electra to v2.8. It is a major update, which is available for free. It includes a big GUI with 6 different sizes, enhanced sound, higher performance, new features, and lots of improvements. Electra 2.8 is downward compatible with all previous versions. All existing song projects and patches can be loaded without any further steps necessary. They will benefit from the enhanced sound quality.

New features:

  • A big interface is available beside the normal scale now.
  • It is possible to select from 6 GUI sizes by clicking on ‘SIZE’.
  • The plugin detects the screen-resolution and selects the best size automatically.
  • The filter-display, the OSC-display, the LFO-display, and the envelope-display are animated when automation or Midi-learn is used.
  • Pitchwheel and Modwheel are animated when the patch-browser is visible.
  • Added Notarisation for the installers on Mac.
  • Support for Code-Signing on the Mac, since new hosts may require it to be able to run plugins.
  • Compatibility with macOS Catalina.
  • Completely new AudioUnit interface.

Enhancements:

  • The plugin and songs are loading, saving, opening and closing faster
  • Better compatibility with other plugins
  • More intuitive handling of sample-loops.
  • Better descriptions for some tool-tips.
  • Many small enhancements for the user-interface.
  • Fixed some typos.
  • More contrast for the pitch-wheel and mod-wheel in the patch-browser.
  • More accurate timing for Midi-events.
  • More accurate processing of Midi-pitch wheel.

Enhanced sound-quality:

  • Slightly enhanced the sound of PingPong, Delay, and Delay-Diffuse by reducing the detuning.
  • Enhanced sound and default-settings for Delay-Band and Multitap.
  • Enhanced sound and performance of Reverb-Hall and Reverb-Cathedral.
  • Enhanced sound-quality of sample-playback in high octaves.

Changes:

  • 32 bit on Mac is no longer supported. If you still use it, install Electra 2.7 instead.
  • MacOS 10.7 is the minimum requirement now. If you still use 10.6 or 10.5, install Electra 2.7.

Product Page: Tone2 Electra 2

Leave a Reply

Your email address will not be published. Required fields are marked *